What’s Vulnerable › Vulnerabilities
CVE-2026-34760: vLLM: Downmix Implementation Differences as Attack Vectors Against Audio AI Models
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-02 · updated 2026-07-24
- Weakness: CWE-20
Description
vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before version 0.18.0, Librosa defaults to using numpy.mean for mono downmixing (to_mono), while the international standard ITU-R BS.775-4 specifies a weighted downmixing algorithm. This discrepancy results in inconsistency between audio heard by humans (e.g., through headphones/regular speakers) and audio processed by AI models (Which infra via Librosa, such as vllm, transformer). This issue has been patched in version 0.18.0.
Affected products
- vllm-project vllm: from 0.5.5 before 0.18.0 — fixed in 0.18.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/c7f98b4d0a63b32ed939e2b6dfaa8a626e9b46c4
- https://github.com/vllm-project/vllm/pull/37058
- https://github.com/vllm-project/vllm/releases/tag/v0.18.0
- https://github.com/vllm-project/vllm/security/advisories/GHSA-6c4r-fmh3-7rh8
Get alerted when CVE-2026-34760 or the next vulnerability affects your stack