What’s Vulnerable › Vulnerabilities

CVE-2026-34877

Description

An issue was discovered in Mbed TLS versions from 2.19.0 up to 3.6.5, Mbed TLS 4.0.0. Insufficient protection of serialized SSL context or session structures allows an attacker who can modify the serialized structures to induce memory corruption, leading to arbitrary code execution. This is caused by Incorrect Use of Privileged APIs.

Affected products

How to fix

Upgrade to a fixed version: mbedtls 3.6.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-34877 or the next vulnerability affects your stack