What’s Vulnerable › Vulnerabilities
CVE-2026-34884: Apache SkyWalking MCP: SSRF via set_skywalking_url Tool and GraphQL Expression Injection in MCP Server
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-918
Description
SSRF via set_skywalking_url Tool and GraphQL expression injection vulnerability in Apache SkyWalking MCP. This issue affects Apache SkyWalking MCP: 0.1.0. Users are recommended to upgrade to version 0.2.0, which fixes this issue.
Affected products
- Apache Software Foundation Apache SkyWalking MCP: from 0.1.0 before 0.2.0 — fixed in 0.2.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache SkyWalking MCP 0.2.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/s447p6h5dfr02lx17v27phoksgb8mkkp
- http://www.openwall.com/lists/oss-security/2026/04/13/5
Get alerted when CVE-2026-34884 or the next vulnerability affects your stack