What’s Vulnerable › Vulnerabilities
CVE-2026-34931: hoppscotch: Improper loopback redirect_uri validation in device-login flow
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-02 · updated 2026-07-24
- Weakness: CWE-601
Description
hoppscotch is an open source API development ecosystem. Prior to version 2026.3.0, there is an open redirect vulnerability that leads to token exfiltration. With these tokens, the attacker can sign in as the victim to takeover their account. This issue has been patched in version 2026.3.0.
Affected products
- hoppscotch: before 2026.3.0 — fixed in 2026.3.0
How to fix
Upgrade to a fixed version: hoppscotch 2026.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/hoppscotch/hoppscotch/releases/tag/2026.3.0
- https://github.com/hoppscotch/hoppscotch/security/advisories/GHSA-7fg7-wx5q-6m3v
Get alerted when CVE-2026-34931 or the next vulnerability affects your stack