What’s Vulnerable › Vulnerabilities
CVE-2026-34951: Reflected XSS in footer.php in Workbench Allows Attackers to Hijack Authenticated Sessions
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-06 · updated 2026-10-24
- Weakness: CWE-79
Description
Workbench is a suite of tools for administrators and developers to interact with Salesforce.com organizations via the Force.com APIs. Prior to 65.0.0, Workbench contains a reflected cross-site scripting vulnerability via the footerScripts parameter, which does not sanitize user-supplied input before rendering it in the page response. Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Workbench allows XSS Targeting Error Pages. This vulnerability is fixed in 65.0.0.
Affected products
- Salesforce Workbench: before 65.0.0 — fixed in 65.0.0
How to fix
Upgrade to a fixed version: Salesforce Workbench 65.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34951 or the next vulnerability affects your stack