What’s Vulnerable › Vulnerabilities
CVE-2026-34972: OpenFGA's BatchCheck within-request deduplication produces incorrect authorization decisions via list-value cache-key collision
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-06 · updated 2026-07-24
- Weakness: CWE-863
Description
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. From 1.8.0 to 1.13.1, under specific conditions, BatchCheck calls with multiple checks sent for the same object, relation, and user combination can result in improper policy enforcement. This vulnerability is fixed in 1.14.0.
Affected products
- openfga Helm Charts: from 0.2.16 before 0.2.62 — fixed in 0.2.62
- openfga: from 1.8.0 before 1.14.0 — fixed in 1.14.0
How to fix
Upgrade to a fixed version: openfga Helm Charts 0.2.62; openfga 1.14.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34972 or the next vulnerability affects your stack