What’s Vulnerable › Vulnerabilities
CVE-2026-35029: LiteLLM affected by privilege escalation via unrestricted proxy configuration endpoint
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 38.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-06 · updated 2026-10-23
- Weakness: CWE-863
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.0, the /config/update endpoint does not enforce admin role authorization. A user who is already authenticated into the platform can then use this endpoint to modify proxy configuration and environment variables, register custom pass-through endpoint handlers pointing to attacker-controlled Python code, achieving remote code execution, read arbitrary server files by setting UI_LOGO_PATH and fetching via /get_image, and take over other privileged accounts by overwriting UI_USERNAME and UI_PASSWORD environment variables. Fixed in v1.83.0.
Affected products
- BerriAI litellm: before 1.83.0 — fixed in 1.83.0
How to fix
Upgrade to a fixed version: BerriAI litellm 1.83.0. Check the vendor advisory for mitigations.
References
- https://github.com/BerriAI/litellm/security/advisories/GHSA-53mr-6c8q-9789
- http://seclists.org/fulldisclosure/2026/Apr/17
- https://access.redhat.com/errata/RHSA-2026:13545
- https://access.redhat.com/errata/RHSA-2026:28960
- https://access.redhat.com/errata/RHSA-2026:30056
- https://access.redhat.com/security/cve/CVE-2026-35029
- https://bugzilla.redhat.com/show_bug.cgi?id=2455474
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-35029.json
Get alerted when CVE-2026-35029 or the next vulnerability affects your stack