What’s Vulnerable › Vulnerabilities
CVE-2026-35042: fast-jwt accepts unknown `crit` header extensions (RFC 7515 §4.1.11 MUST violation)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-06 · updated 2026-10-24
- Weakness: CWE-345
Description
fast-jwt provides fast JSON Web Token (JWT) implementation. In 6.1.0 and earlier, fast-jwt does not validate the crit (Critical) Header Parameter defined in RFC 7515 §4.1.11. When a JWS token contains a crit array listing extensions that fast-jwt does not understand, the library accepts the token instead of rejecting it. This violates the MUST requirement in the RFC.
Affected products
- nearform fast-jwt: before 6.2.0 — fixed in 6.2.0
How to fix
Upgrade to a fixed version: nearform fast-jwt 6.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/nearform/fast-jwt/security/advisories/GHSA-hm7r-c7qw-ghp6
- https://www.rfc-editor.org/rfc/rfc7515.html#section-4.1.11
- https://github.com/nearform/fast-jwt/security/advisories/GHSA-hm7r-c7qw-ghp6
Get alerted when CVE-2026-35042 or the next vulnerability affects your stack