What’s Vulnerable › Vulnerabilities
CVE-2026-35054: XenForo Stored Cross-Site Scripting via BB Code Rendering
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-01 · updated 2026-06-17
- Weakness: CWE-79
Description
XenForo before 2.3.9 is vulnerable to stored cross-site scripting (XSS) related to BB code rendering. An attacker can inject malicious scripts through BB code that are stored and executed when other users view the content.
Affected products
- XenForo: before 2.3.9 — fixed in 2.3.9
How to fix
Upgrade to a fixed version: XenForo 2.3.9. Check the vendor advisory for mitigations.
References
- https://www.vulncheck.com/advisories/xenforo-stored-cross-site-scripting-via-bb-code-rendering
- https://xenforo.com/community/threads/xenforo-2-3-9-inc-xfmg-2-2-18-released-security-fix.235659/
Get alerted when CVE-2026-35054 or the next vulnerability affects your stack