What’s Vulnerable › Vulnerabilities

CVE-2026-35058

Description

Improper validation of packet length during tls-crypt-v2 key extraction in OpenVPN 2.6.0 through 2.6.19 and 2.7_alpha1 through 2.7.1 allows authenticated attackers to trigger a fatal assertion and cause a denial of service via a specially crafted packet.

Affected products

How to fix

Upgrade to a fixed version: OpenVPN 2.6.20, 2.7.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-35058 or the next vulnerability affects your stack