What’s Vulnerable › Vulnerabilities
CVE-2026-35093: Libinput: libinput: unauthorized code execution and information disclosure through lua bytecode plugins
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-01 · updated 2026-10-26
- Weakness: CWE-94
Description
A flaw was found in libinput. A local attacker who can place a specially crafted Lua bytecode file in certain system or user configuration directories can bypass security restrictions. This allows the attacker to run unauthorized code with the same permissions as the program using libinput, such as a graphical compositor. This could lead to the attacker monitoring keyboard input and sending that information to an external location.
Affected products
- Fedoraproject Fedora: 43, 44
- libinput: before 1.30.3; from 1.30.4 before 1.31.1 — fixed in 1.30.3, 1.31.1
How to fix
Upgrade to a fixed version: libinput 1.30.3, 1.31.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2026-35093
- https://bugzilla.redhat.com/show_bug.cgi?id=2453839
- https://gitlab.freedesktop.org/libinput/libinput/-/work_items/1271
- https://access.redhat.com/security/cve/CVE-2026-35093
- https://bugzilla.redhat.com/show_bug.cgi?id=2453839
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-35093.json
Get alerted when CVE-2026-35093 or the next vulnerability affects your stack