What’s Vulnerable › Vulnerabilities
CVE-2026-35159
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-03 · updated 2026-07-07
- Weakness: CWE-305
Description
Dell Client Platform BIOS contains an Authentication Bypass by Primary Weakness vulnerability. An unauthenticated attacker with physical access could potentially exploit this vulnerability, leading to Information Disclosure.
Affected products
- Dell 14 Plus 2-in-1 DB04250: before 1.13.0 or later — fixed in 1.13.0 or later
- Dell 14 Plus DB14250: before 1.13.0 or later — fixed in 1.13.0 or later
- Dell 15 DC15250: before 1.10.0 or later — fixed in 1.10.0 or later
- Dell 16 Plus 2-in-1 DB06250: before 1.13.0 or later — fixed in 1.13.0 or later
- Dell 16 Plus DB16250: before 1.13.0 or later — fixed in 1.13.0 or later
- Dell 24 All-in-One EC24250: before 1.15.0 or later — fixed in 1.15.0 or later
- Dell 27 All-in-One EC27250: before 1.15.0 or later — fixed in 1.15.0 or later
- Dell Alienware 16 Area-51 AA16250: before 2.4.1 or later — fixed in 2.4.1 or later
- Dell Alienware 16 Aurora AC16250: before 1.13.0 or later — fixed in 1.13.0 or later
- Dell Alienware 16X Aurora AC16251: before 2.4.0 or later — fixed in 2.4.0 or later
- Dell Alienware 18 Area-51 AA18250: before 2.4.1 or later — fixed in 2.4.1 or later
- Dell Alienware Area-51 AAT2250: before 1.17.2 or later — fixed in 1.17.2 or later
- Dell Alienware Aurora ACT1250: before 1.16.2 or later — fixed in 1.16.2 or later
- Dell Alienware m15 R6: before 1.44.0 or later — fixed in 1.44.0 or later
- Dell Alienware m15 R7: before 1.40.0 or later — fixed in 1.40.0 or later
- Dell Alienware m16 R1: before 1.34.0 or later — fixed in 1.34.0 or later
- Dell Alienware m16 R2: before 1.21.0 or later — fixed in 1.21.0 or later
- Dell Alienware m18 R1: before 1.34.0 or later — fixed in 1.34.0 or later
- Dell Alienware M18 R2: before 1.22.0 or later — fixed in 1.22.0 or later
- Dell Alienware x14 R2: before 1.32.0 or later — fixed in 1.32.0 or later
- Dell Alienware x16 R1: before 1.32.0 or later — fixed in 1.32.0 or later
- Dell Alienware X16 R2: before 1.22.0 or later — fixed in 1.22.0 or later
- Dell ChengMing 3900: before 1.40.0 or later — fixed in 1.40.0 or later
- Dell ChengMing 3910/3911: before 1.36.0 or later — fixed in 1.36.0 or later
- Dell 14 DC14250: before 1.7.0 or later — fixed in 1.7.0 or later
- Dell G15 5510: before 1.40.0 or later — fixed in 1.40.0 or later
- Dell G15 5511: before 1.43.0 or later — fixed in 1.43.0 or later
- Dell G15 5520: before 1.41.0 or later — fixed in 1.41.0 or later
- Dell G15 5530: before 1.33.0 or later — fixed in 1.33.0 or later
- Dell G16 7620: before 1.41.0 or later — fixed in 1.41.0 or later
How to fix
Upgrade to a fixed version: Dell 14 Plus 2-in-1 DB04250 1.13.0 or later; Dell 14 Plus DB14250 1.13.0 or later; Dell 15 DC15250 1.10.0 or later; Dell 16 Plus 2-in-1 DB06250 1.13.0 or later; Dell 16 Plus DB16250 1.13.0 or later; Dell 24 All-in-One EC24250 1.15.0 or later; Dell 27 All-in-One EC27250 1.15.0 or later; Dell Alienware 16 Area-51 AA16250 2.4.1 or later; Dell Alienware 16 Aurora AC16250 1.13.0 or later; Dell Alienware 16X Aurora AC16251 2.4.0 or later; Dell Alienware 18 Area-51 AA18250 2.4.1 or later; Dell Alienware Area-51 AAT2250 1.17.2 or later. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-35159 or the next vulnerability affects your stack