What’s Vulnerable › Vulnerabilities
CVE-2026-35174: Chyrp Lite has a Path Traversal to Remote Code Execution
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-06 · updated 2026-07-24
- Weakness: CWE-22
Description
Chyrp Lite is an ultra-lightweight blogging engine. Prior to 2026.01, a path traversal vulnerability exists in the administration console that allows an administrator or a user with Change Settings permission to change the uploads path to any folder. This vulnerability allows the user to download any file on the server, including config.json.php with database credentials and overwrite critical system files, leading to remote code execution. This vulnerability is fixed in 2026.01.
Affected products
- xenocrat chyrp-lite: before 2026.01 — fixed in 2026.01
How to fix
Upgrade to a fixed version: xenocrat chyrp-lite 2026.01. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-35174 or the next vulnerability affects your stack