What’s Vulnerable › Vulnerabilities
CVE-2026-35177: Path traversal issue with zip.vim in Vim
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-06 · updated 2026-07-24
- Weakness: CWE-22
Description
Vim is an open source, command line text editor. Prior to 9.2.0280, a path traversal bypass in Vim's zip.vim plugin allows overwriting of arbitrary files when opening specially crafted zip archives, circumventing the previous fix for CVE-2025-53906. This vulnerability is fixed in 9.2.0280.
Affected products
- vim/vim: before 9.2.0280 — fixed in 9.2.0280
How to fix
Upgrade to a fixed version: vim/vim 9.2.0280. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-35177 or the next vulnerability affects your stack