What’s Vulnerable › Vulnerabilities
CVE-2026-35194: Apache Flink: Remote code execution via SQL injection in code generation
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-15 · updated 2026-10-26
- Weakness: CWE-94
Description
Code injection in SQL code generation in Apache Flink 1.15.0 through 1.20.x and 2.0.0 through 2.x allows authenticated users with query submission privileges to execute arbitrary code on TaskManagers via maliciously crafted SQL queries. The vulnerability affects JSON functions (1.15.0+) and LIKE expressions with ESCAPE clauses (1.17.0+). User-controlled strings are interpolated into generated Java code without proper escaping, allowing attackers to break out of string literals and inject arbitrary expressions. Users are recommended to upgrade to either version 1.20.4, 2.0.2, 2.1.2 or 2.2.1, which fixes this issue.
Affected products
- Apache Software Foundation Apache Flink: from 1.15.0 before 1.20.4; from 2.0.0 before 2.0.2; from 2.1.0 before 2.1.2; 2.2.0, 2.2.0-rc1, 2.2.0-rc2 — fixed in 1.20.4, 2.0.2, 2.1.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Flink 1.20.4, 2.0.2, 2.1.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/qh52bw4hhvy7n2owd8b3bt51mz0lvj9x
- http://www.openwall.com/lists/oss-security/2026/05/15/20
Get alerted when CVE-2026-35194 or the next vulnerability affects your stack