What’s Vulnerable › Vulnerabilities
CVE-2026-35197: Code injection in dye template expressions
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-06 · updated 2026-07-24
- Weakness: CWE-94
Description
dye is a portable and respectful color library for shell scripts. Prior to 1.1.1, certain dye template expressions would result in execution of arbitrary code. This issue was discovered and fixed by dye's author, and is not known to be exploited. This vulnerability is fixed in 1.1.1.
Affected products
- mattieb dye: 1.1.0
References
- https://github.com/mattieb/dye/security/advisories/GHSA-3v4r-5vfh-3wjr
- https://mattiebee.io/dye-template-advisory
Get alerted when CVE-2026-35197 or the next vulnerability affects your stack