What’s Vulnerable › Vulnerabilities
CVE-2026-3520: Multer vulnerable to Denial of Service via uncontrolled recursion
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-04 · updated 2026-07-15
- Weakness: CWE-674
Description
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow. Users should upgrade to version 2.1.1 to receive a patch. No known workarounds are available.
Affected products
- multer: before 2.1.1 — fixed in 2.1.1
How to fix
Upgrade to a fixed version: multer 2.1.1. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/expressjs/multer/commit/7e66481f8b2e6c54b982b34c152479e096ce2752
- https://github.com/expressjs/multer/security/advisories/GHSA-5528-5vmv-3xc2
- https://www.cve.org/CVERecord?id=CVE-2026-3520
- https://access.redhat.com/errata/RHSA-2026:6174
- https://access.redhat.com/errata/RHSA-2026:6802
- https://access.redhat.com/security/cve/CVE-2026-3520
- https://bugzilla.redhat.com/show_bug.cgi?id=2444584
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-3520.json
Get alerted when CVE-2026-3520 or the next vulnerability affects your stack