What’s Vulnerable › Vulnerabilities
CVE-2026-35204: Helm has a path traversal in plugin metadata version enables arbitrary file write outside Helm plugin directory
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-09 · updated 2026-07-15
- Weakness: CWE-22
Description
Helm is a package manager for Charts for Kubernetes. From 4.0.0 to 4.1.3, a specially crafted Helm plugin, when installed or updated, will cause Helm to write the contents of the plugin to an arbitrary filesystem location. To prevent this, validate that the plugin.yaml of the Helm plugin does not include a version: field containing POSIX dot-dot path separators ie. "/../". This vulnerability is fixed in 4.1.4.
Affected products
- helm: from 4.0.0 before 4.1.4 — fixed in 4.1.4
How to fix
Upgrade to a fixed version: helm 4.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/helm/helm/commit/36c8539e99bc42d7aef9b87d136254662d04f027
- https://github.com/helm/helm/releases/tag/v4.1.4
- https://github.com/helm/helm/security/advisories/GHSA-vmx8-mqv2-9gmg
- https://access.redhat.com/errata/RHSA-2026:26441
- https://access.redhat.com/security/cve/CVE-2026-35204
- https://bugzilla.redhat.com/show_bug.cgi?id=2456933
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-35204.json
Get alerted when CVE-2026-35204 or the next vulnerability affects your stack