What’s Vulnerable › Vulnerabilities
CVE-2026-35387
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-02 · updated 2026-07-24
- Weakness: CWE-670
Description
OpenSSH before 10.3 can use unintended ECDSA algorithms. Listing of any ECDSA algorithm in PubkeyAcceptedAlgorithms or HostbasedAcceptedAlgorithms is misinterpreted to mean all ECDSA algorithms.
Affected products
- OpenSSH: before 10.3 — fixed in 10.3
How to fix
Upgrade to a fixed version: OpenSSH 10.3. Check the vendor advisory for mitigations.
References
- https://marc.info/?l=openssh-unix-dev&m=177513443901484&w=2
- https://www.openssh.org/releasenotes.html#10.3p1
- https://www.openwall.com/lists/oss-security/2026/04/02/3
Get alerted when CVE-2026-35387 or the next vulnerability affects your stack