What’s Vulnerable › Vulnerabilities
CVE-2026-35401: Saleor has a resource exhaustion vulnerability in GraphQL queries
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-08 · updated 2026-07-24
- Weakness: CWE-770
Description
Saleor is an e-commerce platform. From 2.0.0 to before 3.23.0a3, 3.22.47, 3.21.54, and 3.20.118, a malicious actor can include many GraphQL mutations or queries in a single API call using aliases or chaining multiple mutations, resulting in resource exhaustion. This vulnerability is fixed in 3.23.0a3, 3.22.47, 3.21.54, and 3.20.118.
Affected products
- saleor: from 2.0.0 before 3.20.118; from 3.21.0 before 3.21.54; from 3.22.0 before 3.22.47; 3.23.0-alpha0, 3.23.0-alpha1, 3.23.0-alpha2 — fixed in 3.20.118, 3.21.54, 3.22.47
How to fix
Upgrade to a fixed version: saleor 3.20.118, 3.21.54, 3.22.47. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-35401 or the next vulnerability affects your stack