What’s Vulnerable › Vulnerabilities
CVE-2026-3547: wolfSSL: out-of-bounds read (DoS) in ALPN parsing due to incomplete validation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-125
Description
Out-of-bounds read in ALPN parsing due to incomplete validation. wolfSSL 5.8.4 and earlier contained an out-of-bounds read in ALPN handling when built with ALPN enabled (HAVE_ALPN / --enable-alpn). A crafted ALPN protocol list could trigger an out-of-bounds read, leading to a potential process crash (denial of service). Note that ALPN is disabled by default, but is enabled for these 3rd party compatibility features: enable-apachehttpd, enable-bind, enable-curl, enable-haproxy, enable-hitch, enable-lighty, enable-jni, enable-nginx, enable-quic.
Affected products
- wolfSSL: before 5.9.0 — fixed in 5.9.0
How to fix
Upgrade to a fixed version: wolfSSL 5.9.0. Check the vendor advisory for mitigations.
In the news
References
Get alerted when CVE-2026-3547 or the next vulnerability affects your stack