What’s Vulnerable › Vulnerabilities
CVE-2026-35476: InvenTree Affected by Privilege Escalation via API
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-08 · updated 2026-10-06
- Weakness: CWE-285
Description
InvenTree is an Open Source Inventory Management System. Prior to 1.2.7 and 1.3.0, a non-staff authenticated user can elevate their account to a staff level via a POST request against their user account endpoint. The write permissions on the API endpoint are improperly configured, allowing any user to change their staff status. This vulnerability is fixed in 1.2.7 and 1.3.0.
Affected products
- InvenTree: through 1.2.6
References
- https://docs.inventree.org/en/stable/concepts/threat_model/#assumed-trust
- https://github.com/inventree/InvenTree/security/advisories/GHSA-r8q5-3595-3jh2
Get alerted when CVE-2026-35476 or the next vulnerability affects your stack