What’s Vulnerable › Vulnerabilities
CVE-2026-35479: InvenTree Plugin Installation - Insufficient Permissions
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-08 · updated 2026-10-06
- Weakness: CWE-285
Description
InvenTree is an Open Source Inventory Management System. Prior to 1.2.7 and 1.3.0, any users who have staff access permissions can install plugins via the API, without requiring "superuser" account access. This level of permission requirement is out of alignment with other plugin actions (such as uninstalling) which do require superuser access. The vulnerability allows staff users (who may be considered to have a lower level of trust than a superuser account) to install arbitrary (and potentially harmful) plugins. This vulnerability is fixed in 1.2.7 and 1.3.0.
Affected products
- InvenTree: before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: InvenTree 1.2.7. Check the vendor advisory for mitigations.
References
- https://docs.inventree.org/en/stable/concepts/threat_model/#assumed-trust
- https://docs.inventree.org/en/stable/start/config/#plugin-options
- https://github.com/inventree/InvenTree/security/advisories/GHSA-7c3q-vwcv-2vp7
Get alerted when CVE-2026-35479 or the next vulnerability affects your stack