What’s Vulnerable › Vulnerabilities
CVE-2026-35569: ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-15 · updated 2026-10-26
- Weakness: CWE-79
Description
ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain a stored cross-site scripting vulnerability in SEO-related fields (SEO Title and Meta Description), where user-controlled input is rendered without proper output encoding into HTML contexts including <title> tags, <meta> attributes, and JSON-LD structured data. An attacker can inject a payload such as "></title><script>alert(1)</script> to break out of the intended HTML context and execute arbitrary JavaScript in the browser of any authenticated user who views the affected page. This can be leveraged to perform authenticated API requests, access sensitive data such as usernames, email addresses, and roles via internal APIs, and exfiltrate it to an attacker-controlled server. This issue has been fixed in version 4.29.0.
Affected products
- apostrophecms apostrophe: before 4.29.0 — fixed in 4.29.0
How to fix
Upgrade to a fixed version: apostrophecms apostrophe 4.29.0. Check the vendor advisory for mitigations.
References
- https://github.com/Chittu13/cve-research/tree/main/CVE-2026-35569
- https://github.com/apostrophecms/apostrophe/commit/0e57dd07a56ae1ba1e3af646ba026db4d0ab5bb3
- https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-855c-r2vq-c292
Get alerted when CVE-2026-35569 or the next vulnerability affects your stack