What’s Vulnerable › Vulnerabilities
CVE-2026-35621: OpenClaw < 2026.3.24 - Privilege Escalation via chat.send to Allowlist Persistence
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-10 · updated 2026-06-17
- Weakness: CWE-862
Description
OpenClaw before 2026.3.24 contains a privilege escalation vulnerability where the /allowlist command fails to re-validate gateway client scopes for internal callers, allowing operator.write-scoped clients to mutate channel authorization policy. Attackers can exploit chat.send to build an internal command-authorized context and persist channel allowFrom and groupAllowFrom policy changes reserved for operator.admin scope.
Affected products
- OpenClaw: before 2026.3.24 — fixed in 2026.3.24
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.24. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-94pw-c6m8-p9p9
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-chat-send-to-allowlist-persistence
Get alerted when CVE-2026-35621 or the next vulnerability affects your stack