What’s Vulnerable › Vulnerabilities
CVE-2026-35622: OpenClaw < 2026.3.22 - Improper Authentication Verification in Google Chat Webhook
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-09 · updated 2026-06-17
- Weakness: CWE-290
Description
OpenClaw before 2026.3.22 contains an improper authentication verification vulnerability in Google Chat app-url webhook handling that accepts add-on principals outside intended deployment bindings. Attackers can bypass webhook authentication by providing non-deployment add-on principals to execute unauthorized actions through the Google Chat integration.
Affected products
- OpenClaw: before 2026.3.22 — fixed in 2026.3.22
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.22. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/630f1479c44f78484dfa21bb407cbe6f171dac87
- https://github.com/openclaw/openclaw/commit/a47722de7e3c9cbda8d5512747ca7e3bb8f6ee66
- https://github.com/openclaw/openclaw/security/advisories/GHSA-mp66-rf4f-mhh8
- https://www.vulncheck.com/advisories/openclaw-improper-authentication-verification-in-google-chat-webhook
Get alerted when CVE-2026-35622 or the next vulnerability affects your stack