What’s Vulnerable › Vulnerabilities
CVE-2026-35638: OpenClaw < 2026.3.22 - Privilege Escalation via Self-Declared Scopes in Trusted-Proxy Control UI
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-09 · updated 2026-06-17
- Weakness: CWE-286
Description
OpenClaw before 2026.3.22 contains a privilege escalation vulnerability in the Control UI that allows unauthenticated sessions to retain self-declared privileged scopes without device identity verification. Attackers can exploit the device-less allow path in the trusted-proxy mechanism to maintain elevated permissions by declaring arbitrary scopes, bypassing device identity requirements.
Affected products
- OpenClaw: before 2026.3.22 — fixed in 2026.3.22
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.22. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/630f1479c44f78484dfa21bb407cbe6f171dac87
- https://github.com/openclaw/openclaw/commit/ccf16cd8892402022439346ae1d23352e3707e9e
- https://github.com/openclaw/openclaw/security/advisories/GHSA-48vw-m3qc-wr99
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-self-declared-scopes-in-trusted-proxy-control-ui
Get alerted when CVE-2026-35638 or the next vulnerability affects your stack