What’s Vulnerable › Vulnerabilities
CVE-2026-35639: OpenClaw < 2026.3.22 - Privilege Escalation via device.pair.approve Scope Validation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-09 · updated 2026-06-17
- Weakness: CWE-648
Description
OpenClaw before 2026.3.22 contains a privilege escalation vulnerability in the device.pair.approve method that allows an operator.pairing approver to approve pending device requests with broader operator scopes than the approver actually holds. Attackers can exploit insufficient scope validation to escalate privileges to operator.admin and achieve remote code execution on the Node infrastructure.
Affected products
- OpenClaw: before 2026.3.22 — fixed in 2026.3.22
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.22. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/630f1479c44f78484dfa21bb407cbe6f171dac87
- https://github.com/openclaw/openclaw/commit/fc2d29ea926f47c428c556e92ec981441228d2a4
- https://github.com/openclaw/openclaw/security/advisories/GHSA-hf68-49fm-59cq
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-device-pair-approve-scope-validation
Get alerted when CVE-2026-35639 or the next vulnerability affects your stack