What’s Vulnerable › Vulnerabilities
CVE-2026-35641: OpenClaw < 2026.3.24 - Arbitrary Code Execution via .npmrc in Local Plugin/Hook Installation
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-10 · updated 2026-06-17
- Weakness: CWE-349
Description
OpenClaw before 2026.3.24 contains an arbitrary code execution vulnerability in local plugin and hook installation that allows attackers to execute malicious code by crafting a .npmrc file with a git executable override. During npm install execution in the staged package directory, attackers can leverage git dependencies to trigger execution of arbitrary programs specified in the attacker-controlled .npmrc configuration file.
Affected products
- OpenClaw: before 2026.3.24 — fixed in 2026.3.24
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.24. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-m3mh-3mpg-37hw
- https://www.vulncheck.com/advisories/openclaw-arbitrary-code-execution-via-npmrc-in-local-plugin-hook-installation
- https://github.com/openclaw/openclaw/security/advisories/GHSA-m3mh-3mpg-37hw
Get alerted when CVE-2026-35641 or the next vulnerability affects your stack