What’s Vulnerable › Vulnerabilities
CVE-2026-35645: OpenClaw < 2026.3.25 - Privilege Escalation via Synthetic operator.admin in deleteSession
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-09 · updated 2026-06-17
- Weakness: CWE-648
Description
OpenClaw before 2026.3.25 contains a privilege escalation vulnerability in the gateway plugin subagent fallback deleteSession function that uses a synthetic operator.admin runtime scope. Attackers can exploit this by triggering session deletion without a request-scoped client to execute privileged operations with unintended administrative scope.
Affected products
- OpenClaw: before 2026.3.25 — fixed in 2026.3.25
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.25. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/b5d785f1a59a56c3471f2cef328f7c9a6c15f3e7
- https://github.com/openclaw/openclaw/security/advisories/GHSA-h4jx-hjr3-fhgc
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-synthetic-operator-admin-in-deletesession
Get alerted when CVE-2026-35645 or the next vulnerability affects your stack