What’s Vulnerable › Vulnerabilities

CVE-2026-35651: OpenClaw 2026.2.13 < 2026.3.25 - ANSI Escape Sequence Injection in Approval Prompt

Description

OpenClaw versions 2026.2.13 through 2026.3.24 contain an ANSI escape sequence injection vulnerability in approval prompts that allows attackers to spoof terminal output. Untrusted tool metadata can carry ANSI control sequences into approval prompts and permission logs, enabling attackers to manipulate displayed information through malicious tool titles.

Affected products

How to fix

Upgrade to a fixed version: OpenClaw 2026.3.25. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-35651 or the next vulnerability affects your stack