What’s Vulnerable › Vulnerabilities
CVE-2026-35669: OpenClaw < 2026.3.25 - Privilege Escalation via Gateway Plugin HTTP Authentication Scope
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-10 · updated 2026-06-17
- Weakness: CWE-648
Description
OpenClaw before 2026.3.25 contains a privilege escalation vulnerability in gateway-authenticated plugin HTTP routes that incorrectly mint operator.admin runtime scope regardless of caller-granted scopes. Attackers can exploit this scope boundary bypass to gain elevated privileges and perform unauthorized administrative actions.
Affected products
- OpenClaw: before 2026.3.25 — fixed in 2026.3.25
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.25. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/ec2dbcff9afd8a52e00de054b506c91726d9fbbe
- https://github.com/openclaw/openclaw/security/advisories/GHSA-qm2m-28pf-hgjw
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-gateway-plugin-http-authentication-scope
Get alerted when CVE-2026-35669 or the next vulnerability affects your stack