What’s Vulnerable › Vulnerabilities
CVE-2026-35671: phpMyFAQ - Insecure Direct Object Reference in User Password API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-28 · updated 2026-10-26
- Weakness: CWE-266
Description
phpMyFAQ before 4.1.3 contains an insecure direct object reference vulnerability in the admin API user password endpoint that allows authenticated administrators to change any user's password without authorization verification. An attacker with low-privilege admin credentials can escalate to SuperAdmin by modifying the userId parameter in the overwrite-password API request.
Affected products
- thorsten phpMyFAQ: before 4.1.3 — fixed in 4.1.3
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-xvp4-phqj-cjr3
- https://www.vulncheck.com/advisories/phpmyfaq-insecure-direct-object-reference-in-user-password-api
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-xvp4-phqj-cjr3
Get alerted when CVE-2026-35671 or the next vulnerability affects your stack