What’s Vulnerable › Vulnerabilities

CVE-2026-3582: Incorrect Authorization in GitHub Enterprise Server allows access to issue and commit search results without repo scope

Description

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed an authenticated user with a classic personal access token (PAT) lacking the repo scope to retrieve issues and commits from private and internal repositories via the search REST API endpoints. The user must have had existing access to the repository through organization membership or as a collaborator for the vulnerability to be exploitable. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.20 and was fixed in versions 3.16.15, 3.17.12, 3.18.6 and 3.19.3. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.16.15, 3.17.12, 3.18.6, 3.19.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-3582 or the next vulnerability affects your stack