What’s Vulnerable › Vulnerabilities
CVE-2026-3589: WooCommerce < 10.5.3 - Arbitrary Admin User Creation via CSRF
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-06 · updated 2026-06-17
- Weakness: CWE-352
Description
The WooCommerce WordPress plugin from versions 5.4.0 to 10.5.2 does not properly handle batch requests, which could allow unauthenticated users to make a logged in admin call non store/WC REST endpoints, and create arbitrary admin users via a CSRF attack for example.
Affected products
- Automattic WooCommerce: from 5.4.0 before 5.4.4; from 5.5.0 before 5.4.5; from 5.6.0 before 5.6.3; from 5.7.0 before 5.7.3; from 5.8.0 before 5.8.2; from 5.9.0 before 5.9.2 — fixed in 10.0.6, 10.1.4, 10.2.4, 10.3.8, 10.4.4, 10.5.3
How to fix
Upgrade to a fixed version: Automattic WooCommerce 10.0.6, 10.1.4, 10.2.4, 10.3.8. Check the vendor advisory for mitigations.
References
- https://developer.woocommerce.com/2026/03/02/store-api-vulnerability-patched-in-woocommerce-5-4/
- https://wpscan.com/vulnerability/53ded097-274d-4850-82ee-620bf02f7553/
Get alerted when CVE-2026-3589 or the next vulnerability affects your stack