What’s Vulnerable › Vulnerabilities

CVE-2026-3592: Amplification vulnerabilities via self-pointed glue records

Description

BIND resolvers are vulnerable to an amplified resource consumption/exhaustion attack. If a victim resolver makes a query to a specially crafted zone, the resolver will consume disproportionate resources. This issue affects BIND 9 versions 9.11.0 through 9.16.50, 9.18.0 through 9.18.48, 9.20.0 through 9.20.22, 9.21.0 through 9.21.21, 9.11.3-S1 through 9.16.50-S1, 9.18.11-S1 through 9.18.48-S1, and 9.20.9-S1 through 9.20.22-S1.

Affected products

How to fix

Upgrade to a fixed version: ISC BIND 9.18.49, 9.20.23, 9.21.22. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-3592 or the next vulnerability affects your stack