What’s Vulnerable › Vulnerabilities
CVE-2026-3621: IBM WebSphere Application Server Liberty is affected by identity spoofing
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-23 · updated 2026-10-26
- Weakness: CWE-269
Description
IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.4 IBM WebSphere Application Server Liberty is vulnerable to identity spoofing under limited conditions when an application is deployed without authentication and authorization configured.
Affected products
- IBM WebSphere Application Server: from 17.0.0.3 before 26.0.0.5 — fixed in 26.0.0.5
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 26.0.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-3621 or the next vulnerability affects your stack