What’s Vulnerable › Vulnerabilities

CVE-2026-36214

Description

osTicket versions from 1.10 up to 1.17.7 and from 1.18.0 up to 1.18.3 are vulnerable to a stored XSS due to a vulnerable Bootstrap Tooltip component and insufficient HTML sanitization, allowing remote attackers to execute arbitrary JavaScript in Agent or Admin sessions.

Affected products

How to fix

Upgrade to a fixed version: osticket/osticket 1.17.8, 1.18.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-36214 or the next vulnerability affects your stack