What’s Vulnerable › Vulnerabilities
CVE-2026-3622: Denial-of-Service Vulnerability in UPnP Component of TP Link's TL-WR841N
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-26 · updated 2026-06-17
- Weakness: CWE-125
Description
The vulnerability exists in the UPnP component of TL-WR841N v14, where improper input validation leads to an out-of-bounds read, potentially causing a crash of the UPnP service. Successful exploitation can cause the UPnP service to crash, resulting in a Denial-of-Service condition. This vulnerability affects TL-WR841N v14 < EN_0.9.1 4.19 Build 260303 Rel.42399n (V14_260303) and < US_0.9.1.4.19 Build 260312 Rel. 49108n (V14_0304).
Affected products
- TP-Link TL-WR841N: before 0.9.1_4.19 — fixed in 0.9.1_4.19
How to fix
Upgrade to a fixed version: TP-Link TL-WR841N 0.9.1_4.19. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/en/support/download/tl-wr841n/v14/#Firmware
- https://www.tp-link.com/us/support/download/tl-wr841n/v14/#Firmware
- https://www.tp-link.com/us/support/faq/5033/
Get alerted when CVE-2026-3622 or the next vulnerability affects your stack