What’s Vulnerable › Vulnerabilities

CVE-2026-3637: Mattermost fails to enforce create_post permission when editing posts

Description

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to check the create_post channel permission during post edit operations which allows an authenticated attacker with revoked posting privileges to modify their existing posts via direct API requests to the post update and patch endpoints.. Mattermost Advisory ID: MMSA-2026-00627

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.14, 11.4.4, 11.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-3637 or the next vulnerability affects your stack