What’s Vulnerable › Vulnerabilities
CVE-2026-3691: OpenClaw Client PKCE Verifier Information Disclosure Vulnerability
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-11 · updated 2026-06-17
- Weakness: CWE-200
Description
OpenClaw Client PKCE Verifier Information Disclosure Vulnerability. This vulnerability allows remote attackers to disclose stored credentials on affected installations of OpenClaw. User interaction is required to exploit this vulnerability in that the target must initiate an OAuth authorization flow. The specific flaw exists within the implementation of OAuth authorization. The issue results from the exposure of sensitive data in the authorization URL query string. An attacker can leverage this vulnerability to disclose stored credentials, leading to further compromise. Was ZDI-CAN-29381.
Affected products
- OpenClaw: before 2026.2.25 — fixed in 2026.2.25
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.25. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-6g25-pc82-vfwp
- https://www.zerodayinitiative.com/advisories/ZDI-26-229/
Get alerted when CVE-2026-3691 or the next vulnerability affects your stack