What’s Vulnerable › Vulnerabilities
CVE-2026-38428
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-05 · updated 2026-07-24
- Weakness: CWE-89
Description
Kestra v1.3.3 and before is vulnerable to SQL Injection. The vulnerability occurs because user-controlled input from a GET parameter is directly concatenated into an SQL query without proper sanitization or parameterization. As a result, attackers can inject arbitrary SQL expressions into the database query.
Affected products
- kestra-io kestra: before 1.0.35; from 1.1.0 before 1.3.7 — fixed in 1.0.35, 1.3.7
How to fix
Upgrade to a fixed version: kestra-io kestra 1.0.35, 1.3.7. Check the vendor advisory for mitigations.
References
- https://github.com/kestra-io/kestra/security/advisories/GHSA-365w-2m69-mp9x
- https://www.link.com
- https://github.com/kestra-io/kestra/security/advisories/GHSA-365w-2m69-mp9x
Get alerted when CVE-2026-38428 or the next vulnerability affects your stack