What’s Vulnerable › Vulnerabilities
CVE-2026-3849: Buffer Overflow in HPKE via Oversized ECH Config
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-787
Description
Stack Buffer Overflow in wc_HpkeLabeledExtract via Oversized ECH Config. A vulnerability existed in wolfSSL 5.8.4 ECH (Encrypted Client Hello) support, where a maliciously crafted ECH config could cause a stack buffer overflow on the client side, leading to potential remote execution and client program crash. This could be exploited by a malicious TLS server supporting ECH. Note that ECH is off by default, and is only enabled with enable-ech.
Affected products
- wolfSSL: from 5.6.0 before 5.9.0 — fixed in 5.9.0
How to fix
Upgrade to a fixed version: wolfSSL 5.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-3849 or the next vulnerability affects your stack