What’s Vulnerable › Vulnerabilities

CVE-2026-3855: Improper Control of Resource Identifiers ('Resource Injection') in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2.7 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that under certain conditions could have allowed an authenticated user with project-level permissions to access restricted file contents on the server or cause denial of service due to improper validation of parameters in the Terraform state upload functionality.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.1.8, 19.2.6, 19.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-3855 or the next vulnerability affects your stack