What’s Vulnerable › Vulnerabilities

CVE-2026-3857: Cross-Site Request Forgery (CSRF) in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.10 before 18.8.7, 18.9 before 18.9.3, and 18.10 before 18.10.1 that could have allowed an unauthenticated user to execute arbitrary GraphQL mutations on behalf of authenticated users due to insufficient CSRF protection.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.8.7, 18.9.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-3857 or the next vulnerability affects your stack