What’s Vulnerable › Vulnerabilities
CVE-2026-38820
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-09
- Weakness: CWE-78
Description
openNDS before 11.0.0 is susceptible to unauthenticated OS command execution via shell command injection through the fas query parameter on the /opennds_preauth/ endpoint because of libopennds.sh.
Affected products
- openNDS: before 11.0.0 — fixed in 11.0.0
How to fix
Upgrade to a fixed version: openNDS 11.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-38820 or the next vulnerability affects your stack