What’s Vulnerable › Vulnerabilities
CVE-2026-38821
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-09
- Weakness: CWE-122
Description
A heap-based buffer overflow vulnerability exists in openNDS before 11.0.0 that allows an unauthenticated attacker on the captive portal network to crash the openNDS daemon (denial of service) and potentially achieve remote code execution. This is in http_microhttpd.c.
Affected products
- openNDS: before 11.0.0 — fixed in 11.0.0
How to fix
Upgrade to a fixed version: openNDS 11.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-38821 or the next vulnerability affects your stack