What’s Vulnerable › Vulnerabilities
CVE-2026-3884
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Versions of the package spin.js before 3.0.0 are vulnerable to Cross-site Scripting (XSS) via the spin() function that allows a creation of more than 1 alert for each 'target' element. An attacker would need to set an arbitrary key-value pair on Object.prototype through a crafted URL achieving a prototype pollution first, before being able to execute arbitrary JavaScript in the context of the user's browser.
Affected products
- spin.js: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: spin.js 3.0.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/ericcornelissen/1a73e28fa50c3009b0eb51ad2fc19f25
- https://security.snyk.io/vuln/SNYK-JS-SPINJS-15445079
Get alerted when CVE-2026-3884 or the next vulnerability affects your stack