What’s Vulnerable › Vulnerabilities

CVE-2026-3894: Out-of-bounds Read vulnerability in RTI Connext Professional (Core Libraries) allows Overread Buffers.

Description

Out-of-bounds Read vulnerability in RTI Connext Professional (Core Libraries) allows Overread Buffers. This issue affects Connext Professional: from 7.4.0 before 7.7.0, from 7.0.0 before 7.3.1.3, from 6.1.0 before 6.1.*, from 6.0.0 before 6.0.*, from 5.3.0 before 5.3.*, from 5.2.0 before 5.2.*, from 5.0.0 before 5.1.*.

Affected products

How to fix

Upgrade to a fixed version: RTI Connext Professional 7.7.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-3894 or the next vulnerability affects your stack