What’s Vulnerable › Vulnerabilities
CVE-2026-39087
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-23 · updated 2026-07-04
- Weakness: CWE-777
Description
ntfy before 2.22.0 allows SSRF because of an unanchored regular expression for web push endpoint URLs.
Affected products
- ntfy: before 2.22.0 — fixed in 2.22.0
How to fix
Upgrade to a fixed version: ntfy 2.22.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/MightyNawaf/5d41d6e8ead16e217f86b016002ecae5
- https://github.com/binwiederhier/ntfy/releases/tag/v2.22.0
- https://ntfy.sh
Get alerted when CVE-2026-39087 or the next vulnerability affects your stack